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Downloading a ROBOTC Sample Program
This document is a guide for downloading and running programs on the VEX Cortex using
ROBOTC for Cortex 2.3 BETA. It is broken into four sections: Prerequisites, Downloading Using
USB Only, Downloading Using VEXnet or USB, and Troubleshooting.
You will need:
e 1 VEX Cortex Microcontroller with one 7.2V Robot Battery
* 2 Motor Modules connected to MOTOR ports 2 and 3 on the VEX Cortex
e 1 VEXnet Remote Control with 6 AAA Batteries
* 2 VEXnet USB Adapter Keys
* A computer with ROBOTC for Cortex 2.3 BETA or higher installed
e 1 VEX Programming Kit
e 1 USB A-to-A Cable
Prerequisites
The Cortex, VEXnet Remote Control, and your computer require some configuration before
you are able to program your robot using ROBOTC. This guide assumes that you have already
used ROBOTC to update the firmware on the VEXnet Remote Control, and both the Master and
ROBOTC firmware on the Cortex.
ROBO
! File Edit view | Robot | Window Help
= n ﬁ Compile and Download Program F5 | i= i= A % "/7"‘
Compile Program F7
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Downloading a ROBOTC Sample Program (cont)

Option 1. Downloading Using USB Only

When programming the VEX Cortex, a USB A-to-A cable can be used to directly connect your
computer to the Cortex. This method instructs the robot to immediately run the program stored in
memory when it is powered on, and skips the intial VEXnet link setup. Downloading using USB only is
effective for writing and testing autonomous-only programs that do no require a VEXnet link.

1. Leaving the POWER switch in the OFF position, connect your Cortex to the computer using the USB
A-to-A cable. Once the cable is attached, move the POWER switch to the ON position.

connect your Cortex to your

1b. Turn the Cortex ON

switch on the Cortex to ON.

2. Specify how your Cortex is connected to the computer in the ROBOTC Preferences.

ROBOTC

-

View | Robot Window Help

Function Explorer View

IE‘ Compile Errors View

@ Solution Explarer View Ctrl+

Ctrl+E
[#& Debugger Cutput View
Find In Files View
Font Increase Cirl+=
Font Decrease Ctrl+-

| Preferences

Status Bar

Toolbars...

Show Splash Screen on Startup

Auto Save Before Compile
Open Last Project on Startup

Highlight Program Execution

Compiler Code Generation

2a.

= la. Connect the Cortex to your PC
Use the USB A-to-A cable to

PC.

Make sure a 7.2V Robot battery is
connected and move the POWER

Detailed Preferences...
Go to View > Preferences
and select Detailed
Preferences...

J
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Downloading a ROBOTC Sample Program (cont)

‘ Platform ;u TOirOTITeTTE : 2b. Platform Tab
Make sure that the Platform

Flatform tab is selected on the ROBOTC
VEX 2.0 Cartex 5 | Preferences window.

Communications Port

COM7T (Prolific USB-to-Serial Comm Port) jJ

Automatic Selection

COM1 (Communications Part)

omm Part)

2c. Communication Port
To program directly over the
USB A-to-A cable, select the
option that specifys the USB
Wired Cable. Press OK to
finalize your setting.

3. The ROBOTC Firmware enables you to download ROBOTC programs to your robot and utilize
the various debug windows. Go to Robot > Download Firmware and select Download using
Default File to download the ROBOTC Firmware to your robot.

File

Edit View | Robot | Window Help

H = E ﬁ Compile and Download Program F5

Compile Program F7

{3 . VEX Cortex Download Method 4

_C Constructs Debugger

Debug Windows 4
Remote Control Troubleshooter k

Platform Type 4

Motors and Sensors Setup

Download using Default File

Select and Download Firmware File

| Download Firmware

3. Download Progress
A Download Progress window will appear and begin the download process.
When the window closes, the firmware download is complete.

Note: You only need to download the ROBOTC Firmware once.
Switching programs or download methods does not require a re-download.

/
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Downloading a ROBOTC Sample Program (cont)
4. Go to File and select Open Sample Program to open a ROBOTC sample program.
i| File | Edit View Robot Window Help
Mew... 4
& Open and Compile
HE
o ricE
4. Open a Sample Program
When the Open dialogue box appears,
A b open the Basic Movement folder and
(€] Point Tums.c select Moving Forward.c.
File name: IMDving Forward c j I
Files of type: |C Fies "c:".cop:™h) =l Cancel |
[~ Open as read-only
4
5. Specify the Download Using USB Only as the VEX Cortex Download Method. ROBOTC will remember
your choice, so you do not need to select it every time you download a program.
: File Edit View | Robot | Window Help
3 = n ﬁ Compile and Download Program F5 | = +;§ /‘ % %
i
Compile Program F7
{¢ | VEX Cortex Download Method » Download Using VEXnet or USB =]
- _C Constructs Debugger Crn e AT
- User Defined Debug Windows - Download for Competition (VEXnet) R
Remote Control Troubleshooter g
Platform Type k
- /
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Downloading a ROBOTC Sample Program (cont)

6. Go to Robot and select Compile and Download Program to download the
sample program to the robot.

[
) ROBOTC

: File Edit View | Robot | Window Help
i et = n ﬁ | Compile and Download Program F5 | 4 i=
Compile Program F7
£ VEX Cortex Download Method Plonfig(F
onfig (M
[H- _C Constructs Mishiinnar _ _
[=81= Download Progress |
10%

I

6. Download Progress

A Download Progress window will appear and begin the download process.
When the window closes, the program download is complete.

-

@ Important Information - Power Cycle the VEX Cortex

In addition to ROBOTC, the VEX Cortex also remembers your Download Method
setting. If this is the first time that you have chosen “Download Using USB Only”, or if
you just switched from “Download Using VEXnet USB” or “Download for Competition
(VEXnet)”, you will need to completely power cycle your Cortex (unplug the USB

cable, power the Cortex OFF and then ON) before the updated setting takes effect
and the program runs immediately.

The process of power cycling your Cortex is required any time you switch the
Download Method setting.

7. Run the program on your robot by pressing the Start button on the Program
Debug window, or by power cycling the Cortex.

2400

—Refresh Rate —

I

= Debug Status | |
= ' ————Stepite] on

Clear Al |

Pause Refresh

7a.

Program Debug window

The Program Debug window appears every
time you download a ROBOTC program to
your robot. Press the Start button to run the
program.

Note: Remember that you may need to
power cycle your Cortex for the program to
immediately run, if you are using Download
Using USB Only the first time, or have just
switched from another method.

ROBOTC
\
Setup
N %
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Downloading a ROBOTC Sample Program (cont)

7b. Power Cycle the Cortex
You can also run the program by turning the
Cortex OFF, and then ON.

Note: The USB cable provides some power to

-.ys*_ the Cortex, so it must be unplugged to fully turn

@ P Gy e, a4 the Cortex OFF. Closing the ROBOTC Program

@ Debug window before unplugging the USB

cable is recommended.
8. Observe the sample program running on the robot. The motors plugged into MOTOR
ports 2 and 3 should spin for 3 seconds, according to the ROBOTC program.

26

27 B e T e e o
28 task main()

29 (

30 waitlMsec (2000) ; //Robot waits for 2000 milliseconds be
31

32 J/Move forward at full power for 3 seconds

33 motor [rightMotox] = 127; JS/Motor on port? is run at full (127)
34 motox [leftMotoxr] = 127: JS/Motor on port3 is run at full (127)
35 waitlM=sec (3000) ; //Robot runs previous code for 3000 millised
38 K //Program ends, and the robot stops

37 e e
20

End of Section: Option 1. Downloading Using USB Only

In this section, you learned how to program your robot directly over the USB A-to-A cable.
If you experienced issues with the process, make sure you've follwed every step, and then
reference the troubleshooting section below.

\_ /
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Downloading a ROBOTC Sample Program (cont)
Option 2. Downloading Using VEXnet or USB
When using the VEXnet link to communicate between your computer and the Cortex, downloading
firmware, downloading programs, and using the ROBOTC real-time debugger all work wirelessly. This
guide assumes you have already configured the VEXnet link between your Cortex and VEXnet Remote
Control. Programs downloaded using this method will not run until a VEXnet link has been established
or until 10 seconds have elapsed since the Cortex was powered on.
1. Use the VEX Programming Kit to connect a USB port on your computer to the PROGRAM port on your
VEXnet Remote Control. Turn both the Cortex and VEXnet Remote Control ON and allow them to sync.
2. Specify how your Cortex is connected to the computer in the ROBOTC Preferences.
ROBOTC
View I Robot  Window Help
B =E Function Explorer View
@ Solution Explorer View Cirl -+
{3 . IE' Compile Errars View Ctrl4+E
# _C Const |M Debugger Qutput View
Find In Files View
Font Increase Cirl+=
Font Decrease Ctrl+-
| Preferences P| . Show Splash Screen on Startup
PR Auto Save Before Compile
Open Last Project on Startup
Toolbars...
Highlight Program Execution
Compiler Code Generation
Detailed Preferences ... 2a. Detdailed Preferences...
Go to View > Preferences
and select Detailed
Preferences...
- %
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Downloading a ROBOTC Sample Program (cont)
ROBOTC Preferences E
‘ Platform ;u TOTOTTETTE : 2b. Platform Tab
Make sure that the Platform
Flatform tab is selected on the ROBOTC
VEX 2.0 Cartex 5 | Preferences window.
Communications Port 2c. Communication Port
- - ROBOTC uses the connection
Automatic Selection j between your computer and
Automatic Selection the VEXnet Remote Control to
QU S ormunicat take advantage of the VEXnet
COM7 (Prolif communication link. The
PR T AT T VEXnet Remote Control acts
LUSE Wired Cable # as an intermediary between
ROBOTC and your robot.
Select the port that specifys the
Prolific USB-to-Serial Comm
Port and press OK to finalize
your setting.
3. The ROBOTC Firmware enables you to download ROBOTC programs to your robot and utilize
the various debug windows. Go to Robot > Download Firmware and select Download using
Default File to download the ROBOTC Firmware to your robot.
File Edit View | Robot | Window Help
i et = E ﬁ Compile and Download Program F5
Compile Program F7
£ VEX Cortex Download Method »
_C Constructs Debugger
Debug Windows 4
Remote Control Troubleshooter »
Platform Type 4
Motors and Sensors Setup
| Download Firmware Download using Default File
Select and Download Firmware File
3. Download Progress
A Download Progress window will appear and begin the download process.
When the window closes, the firmware download is complete.
Note: You only need to download the ROBOTC Firmware once.
Switching programs or download methods does not require a re-download.
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Downloading a ROBOTC Sample Program (cont)
4. Go to File and select Open Sample Program to open a ROBOTC Sample Program.
:| File | Edit View Robot Window Help
Mew...
[ Open and Compile
HE
£ Ne Ny s
4. Open a Sample Program
When the Open dialogue box appears,
A b open the Basic Movement folder and
(€] Point Tums.c select Moving Forward.c.
File name: IMDving Forward c j I
Files of type: |C Fies "c:".cop:™h) =l Cancel |
[~ Open as read-only
4
5. Specify the Download Using VEXnet or USB as the VEX Cortex Download Method. ROBOTC will
remember your choice, so you do not need to select it every time you download a program.
! File Edit View | Robot | Window Help
: et = n ﬁ Compile and Download Program F5 | EE = _ A % "/7"‘ % -
| -]
Compile Program F7
{¢ | VEX Cortex Download Method Download Using VEXnet or USB
e
i i T
% _C Constructs Debuager Download Using USE Only .
- ser Defined Debug Windows Download for Competition (VEXnet) i
127 (full forward).
Remote Control Troubleshooter
ORS5 & SEMNSORS:
Platform Type 0 Portd [Mame]
- /
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Downloading a ROBOTC Sample Program (cont)
6. Go to Robot and select Compile and Download Program to download the
sample program to the robot.
: File Edit View | Robot | Window Help
‘i% = n ﬁ | Compile and Download Program F5 | 4 i=
Compile Program F7
£ - VEX Cortex Download Method Plonfig(F
onfig (M
[H- _C Constructs Mishiinnar _ _
e oownioad rogress |
10%
6. Download Progress
A Download Progress window will appear and begin the download process.
When the window closes, the program download is complete.
s N
@ Important Information - Power Cycle the VEX Cortex
In addition to ROBOTC, the VEX Cortex also remembers your Download Method
setting. If this is the first time that you have chosen “Download Using VEXnet or
USB”, or if you just switched from “Download Using USB only” or “Download for
Competition (VEXnet)”, you will need to completely power cycle your Cortex (power
the Cortex OFF and then ON) before the updated setting takes effect and the
program looks for the VEXnet link before running.
The process of power cycling your Cortex is required any time you switch the
Download Method setting.
\ J
7. Run the program on your robot by pressing the Start button on the Program Debug window,
or by power cycling the Cortex.
J
2400
= Debug Status ~ Refresh Rate —
= ' S I Sreph .‘CUI S 7a. Program Debug window
______ The Program Debug window appears every
Clear Al Pause Refresh time you download a ROBOTC program to
= —————— your robot. Press the Start button to run the
program.
Note: Remember that you may need to power
;I cycle your Cortex for the program to establish
a VEXnet link before running, if you are using
Download Using VEXnet or USB the first time,
or have just switched from another method.
)
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Downloading a ROBOTC Sample Program (cont)

7b. Power Cycle the Cortex
You can also run the program by turning the
Cortex OFF, and then ON.

Note: The Cortex will not run the program
until a VEXnet link has been established or
at least 10 seconds have elapsed. Closing
the ROBOTC Program Debug window before
turning off the Cortex is recommended.

8. Observe the sample program running on the robot. The motors plugged into MOTOR

ports 2 and 3 should spin for 3 seconds, according to the ROBOTC program.

27 B e T e e o
8 task main()

29 (

30 waitlMsec (2000) ; //Robot waits for 2000 milliseconds be
31

32 J/Move forward at full power for 3 seconds

33 motor [rightMotox] = 127; JS/Motor on port? is run at full (127)
34 motox [leftMotoxr] = 127: JS/Motor on port3 is run at full (127)
35 waitlM=sec (3000) ; //Robot runs previous code for 3000 millised
38 K //Program ends, and the robot stops

37 e e
20

End of Section: Option2 . Downloading Using VEXnet or USB

In this section, you learned how to program your robot wirelessly using VEXnet.
If you experienced issues with the process, make sure you've follwed every step,
and then reference the troubleshooting section below.

/N

/
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Downloading a ROBOTC Sample Program (cont)

Troubleshooting
Problem: Communication using the USB A-to-A cable between ROBOTC and the Cortex is
very slow, or not working.

Resolution: Verify each of the following options, and re-test your communication link before
moving on:

Is the USB A-to-A cable connecting the computer to your Cortex? The USB cable will provide
some power to the Cortex, powering some of its status lights. If not, try rebooting your system.

Is your robot also connected to and powered on by a charged battery?

Did you have the robot powered on before you connected it to the computer using the USB
A-to-A cable? The robot must first be connected to the computer using the USB A-to-A cable,
and then powered on with the battery.

Is VEX 2.0 Cortex selected as the Platform Type in ROBOTC?

| Platform Type |[] vex 2.0 cortex

Motors and Sensors Setup Previous Platform

Download Firmware 4 Innovation First (IFL) 4 VEX 0.5 Micrachip

. VEX 2.0 Cortex
PC Simulator IFI

-

Have you selected the correct Communication Port in the ROBOTC Preferences?

COM7T (Prolific USB-to-Serial Comm Port) j

Automatic Selection

COM1 (Communications Part)

COM7T (Prolific USB-to-Serial Comm Port)
Active Management Technalo

[Communimtions Part

Have you downloaded the ROBOTC Firmware to the Cortex?
DEDOg vondows F

Remote Control Troubleshooter 4

Platform Type k

Maotors and Sensors Setup

Download Firmware 3

Download using Default File

Select and Download Firmware File

N /
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Downloading a ROBOTC Sample Program (cont)

Troubleshooting

If you've verified all of the previous options with no success, you can enable “Message Tracing”

to put ROBOTC into a persistent communication mode.

Begin by going to Window > Menu Level and selecting Super User to switch your viewing

preferences to the Super User level.

! File Edit View Robot

Window | Help

= é”tl:-| Menu Level

Ring Tone Conwverter

Basic

Then go to View > Preferences and select Detailed Preferences...

| Preferences P|

Delete all Registry Values
Delete All Saved Window Positions

Reset One Time Warning Flags

Status Bar

Show Splash Screen on Startup
Auto Save Before Compile

Open Last Project on Startup
Highlight Program Execution

Compiler Code Generation 4

Toolbars. .. k Detailed Preferences ...

ROBOTC Preferences

Flatfom |

Environment I
Intemal

Directaries I Editor
Compiler I

Compiler Tracing Message Tracing

[™ Trace Token Scanner  None

[™ Trace Register Allocation g

[~ Trace Preprocessor Operation

[ Frequent Intemal Audits

[™ Trace Compiler Steps

" Character Level

" Low Level Messaging

On the Internal tab, select Messages under Message Tracing to put ROBOTC into its persistent
communication mode. Press OK to verify your setting.

I Debugger I Intrinsic Help
Compiler Wamings

Now when you download a program, ROBOTC will also open the Message Log with the

Cortex in a new tab. You can switch back and forth between your program and the Message
Log by clicking on the desired tab.

! Fle Edit View Robot Window Help

BEEH@ BB o[BS A

£~ ROBOTC

pick e g

Moving Forward.c l Message Log ]

= |

{5 -

17663.174

N

17663.178
17863.178

Bg--_C Constructs
#-Debug

Read FEprt
Read FEprt
Reply message **<Reply to

03 00 OD OO OO0 QO 18 DO E& FT7 O]

'Status Data ' (Mo Dat
"Status Data ' " 1' Byf

' DebugGg

N
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